Xcode 4.3.2 (4E2002)错误提示Storyboards are unavailable on iOS 4.3 and prior的解决方法

今天尝试用Xcode建立基于5.0+的Storyboards的项目时发现了一个小bug:尝试将项目Deployment Target切换回4.3编译,然后提示Storyboards are unavailable on iOS 4.3 and prior错误,ok,没问题,5.0的新东西,可以理解,切换target回5.0,编译,错误依旧??!!开始以为是某些涉及版本的设置没有成功修改回来,找了半天,没有发现!详细编译log中提示iPhone和iPad对应的两个storyboard文件编译失败。clean, cmd+q退出重开等方法均无效。最后发现需要清除~/Library/Developer/Xcode/DerivedData中对应当前项目的文件夹,然后重新编译就没问题了,这应该是当前版本Xcode的一个bug,不知什么时候能修正……

博主友情提示:

如在您的评论中需要提及如QQ号、微信号、电子邮件地址或其他隐私敏感信息,欢迎通过>>博主专用加密工具v2<<加密后发布,原文只有博主可以看到。