Win10

解决Windows 10 1903下IPv6地址无法ping通问题

最近发现宽带IPv6通了, https://ipv6-test.com 测试可以正确检测出公网IPv6地址(检测到的是Win10 DHCP出来的临时地址),但是又发现ICMP一直不通,于是找了个也有v6地址的朋友帮忙测试一下,发现果然是ping不通,但是连接功能正常,于是想到是系统自带防火墙(Win10 1903,不确定其它版本是否也有此问题…)的问题,结果在防火墙设置里怎么都改不好,后来在microsoft官方上看到了这个: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/windows-10-firewall-filtering-icmp/527551d0-e477-4dd6-a0a0-eae724940ba3 ,于是照做:

netsh firewall set icmpsetting type=all mode=enable

完事后再测,ICMPv6就能通了,特此记录,以备后需。

Windows 10 1903更新后RDP远程桌面黑屏卡死问题的临时解决方法

最近发现Win10推送了1903更新,迫不及待的装上后还没来得及体验各种变化就发现了一个令人恼火的bug,用远程桌面RDP连接1903版Win10时会出现黑屏卡死的问题!具体状态是RDP服务器是一台CPU比较旧的电脑(G1610 B75 GPU为核显),更新1903之前没任何问题,更新1903后用另一台1903的Win10自带的RDP客户端连接,第一次可以正常连接,断开再重连就必出现黑屏卡死的问题!(同时测试了Android、iOS、Mac OSX上的微软官方RDP客户端连,不会出现卡死的问题!)。搜索了下发现微软官方已经确认了这个问题: https://docs.microsoft.com/en-us/windows/release-information/status-windows-10-1903#534msgdesc ,而目前的状态还是 Investigating ,没有解决方法。

继续阅读…

Win10升级1709后无法匿名访问局域网共享文件夹的问题

今天Win10在一通疯狂硬盘IO后,提示我有重要更新,于是我又愉快的被Win10更新了,更后意识到是近期的1709版被推过来了(之前是1703),多了个“人脉”,别的新鲜还没发现,倒是遇到了个局域网共享访问不了的问题!
博主的路由器上一直开着samba共享,而且是允许匿名访问的,1709更完后突然发现访问出错了,提示的是个0x80004005的错误号(详细信息里),开始以为是这次更新改变了网络设备驱动或是设置,但后来机智的用手机试了下samba访问,发现完全没有问题,于是认定就是这次“重要更新”惹的祸了!
继续阅读…

Flash Builder 4.7在2017年的win10下开发调试的可用打开方式

首先在1703的win10下装好flash builder 4.7,然后新建个as项目,然后调试运行,发现默认的chrome 版本 61.0.3163.100(正式版本) (64 位)打开生成的html页面后根本没有加载flash控件,eclipse的调试部分也完全没有反应,又尝试了非调试运行,结果也是一样加载不了flash。于是更改设置中的浏览器为IE,再试,结果弹出的IE11倒是显示了flash控件,但提示“影片未加载”,显示一片黑!
随后修改运行配置,改为直接执行swf文件,也就是用standalone player的方式运行,结果一切正常!随即想到以前研究fb早期版本时,貌似需要将浏览起的flash插件替换为debug版本,于是17年这个新时代的各种浏览器对flash的恶意就显现出来了…
继续阅读…

从Win8.1升级到Win10后WOL网络唤醒失效的解决方法

之前的Win10各种预览版泄漏版的,虽然也有下过的但一直没来得及安装,最近Win10正式版发布了,而且符合条件的Win7、Win8Win8.1等都收到了更新推送,终于还是强迫症发作,点了下载更新到Win10,更新过程很顺利,但是还没来得及体验就发现了问题:升级之前Win8.1下没问题的WOL网络唤醒功能不能用了!
一度怀疑是路由器上的唤醒设置出错了,但转念一想最近也没修改过设置…后来在关掉Win10后仔细观察了下路由器上的LAN口提示灯发现:原本会有一个低速待机状态的连接提示现在没有了!本来开机的时候是千兆连接的提示灯,关机时是100/10速度连接的提示灯,也就是网卡并没有完全关闭,这是受到唤醒广播包时是可以顺利开机的,而现在连接提示灯是完全熄灭的!
于是开始找原因,发现果然有很多类似案例,升级Win10后WOL不能用了,但大部分是说从Win7升级后出现的,解决方法有关闭“快速启动”、睡眠关机等等,想想我又不是从Win7升级的,解释之前那些解决方法的原因是说Win8以后关机状态的电源模式从S4改成了S5什么的(没记错的话),所以影响了WOL功能。但我升级前在Win8.1下WOL是完全正常的,也没改过什么快速启动等等的设置。最后在远景论坛上看到有人说是Win10更新的“最新驱动”问题,恍然大悟,看了下设备管理器里网卡驱动被更新成了15年4月的一个版本,于是找回主板原配驱动,更新了回去:
QQ截图20150806223752
再次关机,LAN指示灯恢复了低速待机状态,尝试WOL唤醒成功!